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Scenario 1 — How to Configure NAT if you have 

Internet-facing Public Servers 

1.1 Application Scenario  

It is a common practice to place company servers behind the USG’s 

protection; while at the same time letting WAN side clients/servers access 

the intranet servers. To give an example, the company may have an 

internal FTP server, which needs to be accessible from the Internet as well. 

To fulfill this requirement, the user can configure a NAT mapping rule to 

forward the traffic from the Internet side to intranet side. This feature does 

not only ensure service availability, but also helps avoid exposing the 

server’s real IP address from being attacked. 

 

1.2 Configuration Guide 

Goal to achieve:  

User Tom can access the Internet FTP server by accessing the 

Internet-facing the WAN IP address. 

Network Conditions: USG-50:  

- WAN IP: 59.124.163.152  

- FTP server IP: 192.168.50.33 
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Configuration  

Step 1. Go to CONFIGURATION > Network > NAT to open the configuration 

screen.  

 

Step 2. Click on the Add button to create a mapping rule.  

Step 3. In this page, the user needs to configure:  

- Rule’s name  

- Select Virtual Server type to let USG-50 do packet forwarding  

- Fill-in the Original IP (WAN IP) address  

- Fill-in the Mapped IP (Internal FTP server IP) address  

- Select the service to be mapped (FTP); the ports will be selected 

automatically  

 

Step 4. Go to CONFIGURATION > Security Policy > Policy Control to open 

the firewall configuration screen.  

Here assume the user already assigned the WAN interface to WAN zone 

and LAN interface to LAN1 zone.  

Step 5. Click on the Add button to create a firewall rule to enable the FTP 

service to pass from WAN to LAN1.  
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Step 6. The user can create an address object for the internal FTP server for 

further configuration usage. Click on Create new Object for this function.  

 

Step 7. Configure the rule to:  

- Allow access from WAN to LAN1  

- Source IP address is not specific  

- Destination IP address is the FTP server’s address  

- Select FTP service (with port 20/21) to be enabled  

- Select the allow action for matched packets  
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Step 8: Click on the OK button, you will see the rule in policy control. 
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Scenario 2 — Secure Site-to-site Connections 

using IPSec VPN – IPv4 with IKEv2 / IPv6 

2.1 Application Scenario 

IPv4 with IKEv2 

We want to use IKEv2 to establish a VPN tunnel between the HQ and 

Branch Office.  

 

IPv6 (with IKEv2 only) 
ISP has changed the environment to IPv6. We applied for IPv6 address 

pool for internal use. So we have to change use the IPv6 address to 

establish an VPN tunnel between the USG. 

 

2.2 Configuration Guide  

IPv4 

Network Conditions: 

USG-40W with static WAN: 

- WAN IP: 59.124.163.155 
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- Local subnet: 192.168.100.0/24 

 

USG-40W with PPPOE WAN: 

- PPPOE IP: 220.137.67.76 

- Local subnet: 192.168.200.0/24 

 

IPSec VPN Conditions: 

Phase 1: Phase 2: 

IKE version: IKEv2 Active Protocol: ESP  

Authentication: 1234567890  Encapsulation Mode: Tunnel  

Local/Peer ID type: IPv4 0.0.0.0 / 

Any 

Encryption Algorithm: DES  

Encryption Algorithm: 3DES  Authentication Algorithm: SHA1  

Authentication Algorithm: MD5  Perfect Forward Secrecy: None  

Key Group: DH1   

 

Goal to achieve:  

Establish an IPSec VPN tunnel between two USGs with the above 

configuration. 

Step 1. Go to CONFIGURATION > VPN > IPSec VPN > VPN Gateway to open 

the configuration screen.  

Step 2. Click on the Add button to add a VPN gateway rule.  

 

Step 3. To configure the VPN gateway rule, the user needs to fill-in:  

- VPN gateway name 

- Enable IKEv2 protocol 

- Gateway address; both local (My Address) and peer (Peer GW Address)  

- Authentication setting  

 Pre-Shared Key 

 ID Type setting (Local and Peer side) 

- Phase-1 setting 

 Negotiation mode 

 Encryption algorithm 

 Authentication algorithm 
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 Key Group 
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Step 4. Go to CONFIGURATION > VPN > IPSec VPN > VPN Connection to 

open the configuration screen to configure the phase-2 rule.  

 

Step 5. Click on the Add button to add a rule.  

 

 

Step 6. To configure the phase-2 rule, the user needs to fill-in:  

- VPN connection name  

- VPN gateway selection  

-Policy for 

 Local network side 

 Remote network side 

- Phase-2 settings 

 Active protocol 

 Encapsulation mode 

 Encryption algorithm 

 Authentication algorithm 

 Perfect Forward Secrecy 
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Step 7. After setting the rule, the user can select the rule and click on the 

Connect button to establish the VPN link. Once the tunnel is established, a 

connected icon will be displayed in front of the rule.  

 

 

Step 8. When the VPN tunnel is established, the user can find the SA 

information on MONITOR > VPN MONITOR > IPSec. 
 

IPv6 
Step 1. Add an IPV6 VPN phase I on USG1. Go to CONFIGURATION > 

VPN > IPSec VPN > VPN Gateway. 

My Address: 2002:3b7c:a397:2:ee43:f6ff:fefc:c4b3 

Peer Gateway Address: 2002:3b7c:a397:2:b2b2:dcff:fe70:c1d6 

Pre-Shared Key: 12345678 

 

Step 2. Add an IPv6 VPN phase II on USG1. Go to CONFIGURATION > 
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VPN > IPSec VPN > VPN Connection. 

VPN Gateway: USG1_GW 

Local policy: 2002:3b7c:a397:2222::/64 

Remote policy: 2002:3b7c:a397:1111::/64 

 

Step 3. Add an IPV6 VPN phase I on USG2. Go to CONFIGURATION > 

VPN > IPSec VPN > VPN Gateway. 

My Address: 2002:3b7c:a397:2:b2b2:dcff:fe70:c1d6 

Peer Gateway Address: 2002:3b7c:a397:2:ee43:f6ff:fefc:c4b3 

Pre-Shared Key: 12345678 

 

Step 4. Add an IPV6 VPN phase II on USG2. Go to CONFIGURATION > 
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VPN > IPSec VPN > VPN Connection. 

VPN Gateway: USG2_GW 

Local policy: 2002:3b7c:a397:1111::/64 

Remote policy: 2002:3b7c:a397:2222::/64 

 

Step 5. When the VPN tunnel is established, the user can find the SA 

information on  

MONITOR > VPN MONITOR > IPSec.  
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Scenario 3 — Connect to USG using IPSec IKEv2 

in Windows 7 

3.1 Application Scenario 

INTERNET

IKEv2

Lan

192.168.100.1/24

192.168.100.0/24

WAN

usg210.dyndns-ip.com

Windows 7 supports IPSec IKEv2 with certificate authentication. 

This section provides information on how to configure the IKEv2 (Internet 

Key Exchange) on a Windows 7 PC via certificates. 

 

3.2 Configuration Guide 

Network Conditions: 

USG 210: 

- WAN1 IP: usg210.dyndns-ip.com 

- Local subnet: 192.168.100.0/24 

 

USG-210 VPN Conditions: 

Phase 1: 

- Authentication Method: Certificate 

- Local /Peer ID type: DNS / Any 

- Encryption and Authentication Algorithm:  

 3DES/SHA1, AES128/MD5, AES128/SHA1 

- Key Group: DH2 

 

Goal to achieve:  

Establish an IPSec VPN tunnel from Windows 7 using IKEv2 protocol. 
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Step 1. Go to CONFIGURATION > Object > Certificate > My Certificates tab 

to add a new certificate for Windows clients. 

 

 

Step 2. Go to CONFIGURATION > Object > User/Group to create a user 

account. Add this account into IKEv2 users group object. This group object 

will be used in IPSec VPN phase-1 EAP (Extended Authentication Protocol) 

field. 
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Step 3. Go to CONFIGURATION > VPN > IPSec VPN > VPN Gateway to open 

the configuration screen. 

 

Step 4. Click on the Add button to add a VPN gateway rule. 

 

 

Step 5. To configure the VPN gateway rule, the user needs to fill-in: 

- VPN gateway name: 

- IKE Version: IKEv2 

- Gateway address: both local (My Address) and peer (Dynamic Address)  

- Authentication setting: 

 Certificate 

- Phase-1 setting 

 Encryption and Authentication Algorithm:  

1) 3DES / SHA1 

2) AES128 / MD5 

3) AES128 / SHA1 

4) Key Group DH2 

- Extended Authentication Protocol: 

 Enable Extended Authentication Protocol 

Server Mode 

 AAA Method: default 

 Allowed User: IKEv2_users 
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Step 6. Go to CONFIGURATION > Object > Address to create an address 
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object. This address object's IP address will be assigned to the Windows 

IKEv2 client's machine. 

 

 

Step 7. Go to CONFIGURATION > VPN > IPSec VPN > VPN Connection to 

open the configuration screen to configure the phase-2 rule.  

 

Step 8. Click on the Add button to add a rule. 

 

 

Step 9. To configure the phase-2 rule, the user needs to fill-in:  

- VPN connection name  

- VPN gateway selection  

- Policy for  

 Local network side 

- Configuration Payload 

 Enable Configuration Payload 

IP Address Pool: 

- Phase-2 setting 

 Active protocol 

 Encapsulation mode 

 Encryption algorithm 

 Authentication algorithm  

 Perfect Forward Secrecy 
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Step 10. Export the certificate, which was generated in step 1, and save it 

to the Windows 7 machine. 

 

 

Step 11. In the Windows 7 machine, go to Start > mmc >  
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Step 12. In the mmc console, click on File > Add/Remove Snap-in... >  
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Step 13. In the left panel, select the Certificates and click on the Add 

button. 

 

 

Step 14. Select the Computer account > Next button > select Local 

computer > Finish button > OK button. 
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Step 15. Open up the Certificates (Local Computer) > Trusted Root 

Certification Authorities > right-click on Certificate > All Tasks > Import. 
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Step 16. Select the certificate, which was generated by the USG. 

 

 

Step 17. Create the Windows IPSec connection profile. 
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Step 18. Modify the IPSec connection profile. Go to Security >  

Type of VPN: IKEv2  

Data encryption: Requires encryption (disconnect if server declines) 

Authentication: Use Extensible Authentication Protocol (EAP) 
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Step 19. Modify IPSec connection profile. Go to Networking > and disable 

the TCP/IPv6 checkbox. 

Note: USG 4.10 firmware does not support multiple proposals. It only 

supports IPv4 proposal selection. 

 

Step 20. Establish the IPSec tunnel from the Windows 7 machine, and the 

tunnel will be established successfully. 
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Scenario 4 — GRE over IPSec VPN 

Tunnel –VPN Failover  

4.1 Application scenario 

We want to use VPN tunnels to transfer important files between the 

branch Office and HQ. To prevent the network from getting 

disconnected, we configure four WAN interfaces to do redundancy. 

Now, we want to establish two VPN tunnels between the two USGs to 

perform failover, to ensure that the transfer will not be interrupted when 

the first connection encounters a problem. This will create a stable 

environment for the transfer. 

 

4.2 Configuration Guide 

Network conditions:  

USG1 

- WAN1 IP: 192.168.1.33 

- WAN2 IP: 192.168.2.33 

- GRE tunnel interface1: 

10.0.0.1 

- GRE tunnel interface2: 

10.10.0.2 

USG2 

- WAN1 IP: 192.168.3.33 

- WAN2 IP: 192.168.4.33 

- GRE tunnel interface1: 

10.0.0.3 

- GRE tunnel interface2: 

10.10.0.4
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Goals to achieve: 

Use GRE over IPSec VPN to perform the VPN fail-over. 

USG configuration 

Step 1. Add two GRE tunnels on USG1. Go to CONFIGURATION > Tunnel. 

a. Add the first tunnel 

IP Address: 10.0.0.1, Subnet Mask: 255.255.255.0 

My Address: WAN1, Remote Gateway Address: 192.168.3.33 

 
Place a check in the Enable Connectivity Check checkbox. Ensure that the Address is 

the remote GRE tunnel interface. 

 
b. Add the second tunnel 

IP Address: 10.10.0.2, Subnet Mask: 255.255.255.0 

My Address: WAN2, Remote Gateway Address: 192.168.4.33 
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Place a check in the Enable Connectivity Check checkbox. Ensure that the Address is 

the remote GRE tunnel interface. 

 

 
 

Step 2. Add a GRE tunnel trunk on USG1. Go to CONFIGURATION > Network > 

Interface > Trunk. 

 gre_trunk member: 

 tunnel0: Active 

 tunnel1: Passive 



ZyXEL – USG Application Notes 

34 
 

 

 
 

Step3. Add two IPSec VPN tunnels on USG1. Go to CONFIGURATION > VPN > IPSec 

VPN. 

a. Add two VPN gateway policies. 

First VPN Gateway policy (USG1 wan1 to USG2 wan1) 

My Address: wan1, Peer Gateway Address: 192.168.3.33 

Pre-Shared Key: 12345678 
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Secondary Gateway policy (USG1 wan2 to USG2 wan2) 

My Address: wan2, Peer Gateway Address: 192.168.4.33 

Pre-Shared Key: 12345678 

 
b. Add two VPN Connections 

First VPN Connection 

Enable Nailed-Up 

Application Scenario: Site-to-Site 

VPN Gateway: GRE0_GW 

Local policy: 192.168.1.33 

Remote policy: 192.168.3.33 

Enable GRE over IPSec 
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Second VPN Connection 

Enable Nailed-Up 

Application Scenario: Site-to-Site 

VPN Gateway: GRE1_GW 

Local policy: 192.168.2.33 

Remote policy: 192.168.4.33 

Enable GRE over IPSec 
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Step 4. Add a policy routes on USG1. Go to CONFIGURATION> Network > Routing. 

  Source: LAN1_Subnet 

  Destination: Remote subnet 

  Next-Hop: gre_trunk 

  SNAT: none 
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Step5. Add two GRE tunnels on the USG2. Go to CONFIGURATION > Tunnel. 

a. Add first tunnel 

IP Address: 10.0.0.3, Subnet Mask: 255.255.255.0 

My Address: WAN1, Remote Gateway Address: 192.168.1.33 

 
Place a check in the Enable Connectivity Check checkbox. Ensure that the Address is 

the remote GRE tunnel interface. 
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b. Add Second tunnel 

IP Address: 10.10.0.4, Subnet Mask: 255.255.255.0 

My Address: WAN2, Remote Gateway Address: 192.168.2.33 

 
Place a check in the Enable Connectivity Check checkbox. Ensure that the Address is 

the remote GRE tunnel interface. 
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Step6. Add a GRE tunnel trunk on USG2. Go to CONFIGURATION > Network > Interface 

> Trunk. 

 gre_trunk member: 

 tunnel0: Active 

 Tunnel1: Passive 

 

 
 

Step 7. Add two IPSec VPN tunnels on USG2. Go to CONFIGURATION > VPN > IPSec 

VPN. 
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a. Add two VPN Gateways. 

First VPN Gateway 

My Address: wan1, Peer Gateway Address: 192.168.1.33 

Pre-Shared Key: 12345678 

 
Second VPN Gateway 

My Address: wan2, Peer Gateway Address: 192.168.2.33 

Pre-Shared Key: 12345678 

 
b. Add two VPN Connections. 

First VPN connection 

Application Scenario: Site-to-Site 

VPN Gateway: GRE0_GW 

Local policy: 192.168.3.33 

Remote policy: 192.168.1.33 
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Enable GRE over IPSec 

 

 
Second VPN connection 

Enable Nailed-Up 

Application Scenario: Site-to-Site 

VPN Gateway: GRE1_GW 

Local policy: 192.168.4.33 

Remote policy: 192.168.2.33 

Enable GRE over IPSec 
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Step 8. Add a policy routes on USG2. Go to CONFIGURATION > Network > Routing. 

  Source: LAN1_Subnet 

  Destination: Remote subnet 

  Next-Hop: gre_trunk 

  SNAT: none 
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Scenario 5 — Reserving Highest Bandwidth Management Priority for VoIP 

traffic 

 
5.1 Application Scenario 

In an enterprise network, there are various types of traffic. But the company Internet 

connection bandwidth is limited to a specific value. All this traffic will contend to use the 

limited bandwidth, which may result in some important traffic, for example, VoIP traffic 

getting slow or even starved. Therefore, intelligent bandwidth management for improved 

productivity becomes a matter of high concern for network administrators. ZyXEL USG 

provides Bandwidth Management (BWM) function to effectively manage bandwidth 

according to different flexible criteria.  

 

VoIP traffic is quite sensitive to delay and jitter. Therefore, in an enterprise company, VoIP 

traffic should usually be awarded the highest priority over all other types of traffic. 

 

 
 

5.2 Configuration Guide 

Step 1. Go to Configuration > Network > ALG, enable SIP ALG.  

 
 

Step 2. Go to Configuration > BWM > enable BWM and enable Highest Bandwidth Priority 

for SIP Traffic > Apply. 
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Enabling Highest Bandwidth Priority for SIP Traffic forces the device to give SIP traffic the 

highest bandwidth priority. When this option is enabled the system ignores the bandwidth 

management settings of all application patrol rules for SIP traffic and does not record SIP 

traffic bandwidth usage statistics.  
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Scenario 6 - Reserving Highest Bandwidth Management Priority for a 

Superior User and Control Session per Host – BWM Per IP or Per User 
 

6.1 Application Scenario 
 

In an enterprise network, there are various types of traffic. But the company Internet 

connection bandwidth is limited to a specific value. All this traffic will contend to use the 

limited bandwidth, which may result in some important traffic. Therefore, intelligent 

bandwidth management for improved productivity becomes a matter of high concern 

for network administrators. USG provides Bandwidth Management (BWM) function to 

effectively manage bandwidth according to different flexible criteria.  

 

In the USG 4.10 firmware, we have extended the BWM function for a superior user and 

control session per host by only adding one rule. Then the USG can control Per IP or Per 

User to use the limited bandwidth individually. Among all the traffic in the company 

network, sometimes we need to a assign higher priority to some superior users to keep 

their important work going on smoothly. For example, the general managers need to surf 

the Internet smoothly to conduct their daily tasks. Therefore, the network administrator 

should use the bandwidth management function to prioritize the managers’ Internet 

traffic, and guarantee a minimum bandwidth for their own traffic by IP address or by user 

account.  

 

 
 

6.2 Configuration Guide 

BWM Per IP 

Step 1. Go to Configuration > BWM > add the policy to limit the Bandwidth by BWM 

type –Per-Source-IP. 

(1) BWM Type : Per-Source-IP, Source: LAN1_SUBNET 

Note: Object source IP address must belong to class C range which amount can’t 

over 256 users. 
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(2) Inbound = 2000Kbps, Out bound = 2000Kbps, Priority = 1 

 
 

 

 

 

 

 

 

Step 2. Go to Configuration > BWM > Enable BWM function. 

 
 

Step 3. Use the PC’s IP address of “192.168.1.33” to connect to the USG. 

Visit the website http://www.speedtest.net/ to test the speed. 

The test result is around 2 Mbps, which is the same as our setup to manage per source 

IP 2 Mbps. 

http://www.speedtest.net/


ZyXEL – USG Application Notes 

49 
 

 
 

 

Step 4. Use the PC’s IP address of “192.168.1.40” to connect to the USG. 

Visit the website http://www.speedtest.net/ ” to test the speed. 

The test result is around 2 Mbps, which is the same as our setup to manage per source 

IP 2 Mbps. 

 
 

 

BWM Per User- 

Step 1. Go to Configuration > Object > User/Group. 

(1) Add one user name as “user-phone”, and add another user name as “user-pc”. 

http://www.speedtest.net/
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(2) Add these two accounts “user-phone” and “user-pc” into the group as 

“user_local”. 

 
 

 

 

Step 2. Go to Configuration > BWM > Add the policy to limit the Bandwidth by BWM 

type – Per user. 

(1) BWM Type : Per user, User: user_local 

 
 

 

 

(2) Inbound=2000Kbps, Out bound=2000Kbps, Priority =1 



ZyXEL – USG Application Notes 

51 
 

 
 

Step 3. Go to Configuration > BWM > Enable BWM function. 

 
 

Step 4. Verify with the “user-phone” account. 

(1) Enter the “user-phone” user name and password and Login. 

 
 

(2) Visit the website “ http://www.speedtest.net/ ” to test the speed. 

The test result is around 2 Mbps, which is the same as our setup to manage per user 2 

Mbps. 

http://www.speedtest.net/
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ZyXEL – USG Application Notes 

53 
 

Scenario 7 - Using USG to Control Popular Applications –APP Patrol 

 
7.1 Application Scenario 

In the company, the network administrator will need to control access to the Internet for 

internal managers and employees. The USG’s Application Patrol function can take 

corresponding actions according to the configuration in App Patrol. For example, if the 

general managers need to execute the Teamviewer application to access the 

customer’s side to conduct their daily work, then the network administrator can use the 

Firewall to drop other employee that are not allowed to use this type of application, and 

allow only managers to execute Teamviewer application. 

 

 
 

7.2 Configuration Guide 
Step 1. Go to Configuration > Object > Application > Add Application Rule 
For example  
Name: Teamviewer 

 
NOTE: You need to register the IDP/App Patrol license to use App Patrol.  

 

Step 2. Please add Application Object > Search By Service > insert “teamviewer” > 

select all to control all teamviewer applications > and then click on the OK button. 
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Step 3. Go to Configuration > UTM Profile > App Patrol > Profile > Add rule  
For example 
Name: teamviewer_rule. 

 
 

 

Step 4. Go to Profile Management > Add Application  

For example 

Application: choose the application object of “Teamviewer” which you have already 

created. 

Action: drop  

Log: log > ok. 
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Step 5. Go to Configuration > Security policy > Policy Control > Policy > Add 

corresponding > Enable rule  

For example 

Name: teamviewer_drop  

From: LAN1 

UTM Profiles: Enable Application Patrol: choose the application profile of 

“teamviewer_rule” which you have already created. 

Log: by profile > ok > Enable Policy Control, and then App Patrol will work. 

 
 

Step 6. Connect to the PC under USG LAN1, then teamviewer application will not 

open. 

But from other interface can, it can open. 
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Scenario 8 – Configure Unified Policy (Firewall Policy + UTM Profile) 

 

Introduction: 
The unified policy is merging with firewall rule and UTM functions. The flow will check 

the firewall rule first, and then check the UTM function. If the packets are already 

dropped by the firewall rule, then it will not check the UTM rule any more. The 

behavior of policy control is to check for the Initiator source IP address. For example, if 

you would like to block LAN1 users from downloading file from the Internet, then you 

should block From: LAN, To: WAN, Service: FTP, Action: deny. 

If the packets are already dropped by the firewall rule, then it will not check the UTM 

rule any more. 

 
If the packets are allowed by the firewall rule, then you can select the UTM profile to 

control sessions. 
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8.1 Application Scenario 

The customer wants to block Skype and all social networks in LAN1. 

 
8.2 Configuration Guide 

(1) Add a Skype object in Application. 

Go to Configuration > Object > Application, and click on the “Add” button. 

 
(2) Add to the App Patrol profile 
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Go to Configuration > UTM profile > App Patrol, and click on the “Add” button to add 

the application object into the profile. 

 
Add a social network in Content Filter function to drop social networks. 

(3)  
(4) Add a SSL inspection rule to drop the SSL web site to access the social network. 

Go to Configuration > UTM Profile > SSL Inspection > Profile, and click on the “Add” 

button to add a SSL Inspection profile. 

 
(5) Add the policy control rule to drop Skype and social networks from LAN1 subnet. 

Go to Configuration > Security Policy > Policy control > Policy, and click on the “Add” 

button to add the rule, and select the objects into this rule. 
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After configuring these rule, then you can drop Skype and all of the social networks 

successfully. 
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Scenario 9 – Block HTTPS Websites by Content Filter 

Introduction: 
The Content Filter function can distinguish between websites by categories. Since the 

Content Filter does not know that the traffic has already been encrypted, so the 

HTTPS websites cannot be detected. But now can we use the “SSL Inspection” 

function to decrypt the packets, and then to block it. 

 

After enabling the SSL inspection, clients only need to import the certificate 

generated by the USG, because the USG has become a proxy to help to verify these 

HTTPS websites, so client only needs to trust the USG. 

 
After using the SSL inspect function, HTTPs traffic can detect it well by the Content 

Filter function. 

 

9.1 Application Scenario 

Block the search engine in the internal website. 

 

9.2 Configuration Guide 

(1) Create an object in SSL inspection function. 

Go to Configuration > UTM Profile > SSL Inspection > Profile, and click on “Add” to add 

an SSL Inspection object. 
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(2) Create a Content Filter object on the device. 

Go to Configuration > UTM Profile > Content Filter > and click on “Add” to create a 

Content Filter profile. The default setting of “Action Managed Web Page” is “Block”. 

 
 

 

In the Managed Categories select “Search Engines/ Portals” to block the search 

engine. 

 
(3) After Create SSL Inspection and Content Filter profiles, then go to the Policy 

Control function to setup the rule. 

Go to Configuration > Security policy > Policy control and click on the “Add” button 

to add the rule. 

After you setup a session orientation, then you can setup the UTM profile. 

In this example, after you select the profile that you added in this rule, then the end 

user will not be able to access the search engine any more. 
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Verification: Access to https:yahoo.com 
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Scenario 10: Single Sign-on with USG and Windows 

Platform 

 
10.1 Application Scenario 

When the employee’s PC is connected to the company’s network, usually he needs 

to login to the domain first, and then login to the USG with the same username and 

password again, to pass the web authentication before accessing the Internet and 

the company’s resources. With Single Sign-On agent integrated with Microsoft Active 

Directory, the SSO Agent sends authentication information to the USG to let users 

automatically get access to permitted resources. Users just need to login to the 

domain once and have access to the Internet and company internal resources that 

they are authorized to access directly without being prompted to login again. (SSO 

function support for USG110,210,310,1100 and 1900)

 

 
10.2 Configuration Guide 

Network conditions 

WAN: 59.124.163.151 

LAN 1: 192.168.1.0/255.255.255.0 

Domain Controller (Windows Server 2008 R2): 192.168.1.34 

Client’s laptop: 192.168.1.33 
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Goals to achieve 

The user logs into the domain once and is able to access the Internet directly without 

specifying the username and password in the web browser.  

  

Domain Controller Configuration 

1. Go to Active Directory Users and Computers to create a new domain account 

and add it to the group of "Domain Admins". 

Example: ssoadmin 

Create some domain users.  

Example: Amy 

 
SSO Agent Installation 

1. Prepare the package of SSO Agent. 

2. Install .NET Framework v4.0.30319 or above version. 

 
Double click “dotNetFx40_Full_x86_x64.exe”. 
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3. Install Visual C++ 

 
 

Double-click on the “vcredist_x86.exe”. 
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4. Double-click on "SSOAgentInstaller.exe" to install SSO Agent. 

 

 
Click on “Next” to proceed. 
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Select a folder or setup with default location and click on “Next”. 

 
In this scenario, SSO Agent is installed on the Domain Controller.  

Select “DC”. 
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Click on “Next” to start the installation. 

 
 

 

 

 

A dialog box called “Set SSO Agent Service” will pop-up. 

Enter the Domain\Username and password of the domain account that was created 

in Domain Controller configuration. Click on ”OK” to continue. 
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SSO Agent is installed successfully.  

 
 

 

 

 

SSO Agent Installation 

1. Click on “Configure ZyXEL SSO Agent”. 
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2. Click on “Configure” to configure the LDAP query to get group information of users 

from the Active Directory. 

 
 

Configure the IP address of the AD server, Base DN, and Bind DN. 
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Under Gateway Settings, click on “Add” to configure the IP address of the USG and 

the Pre-Shared Key. 

 
Enable SSO service. 
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When the SSO service is started successfully, the icon is enabled. 

 
 

 

USG Configuration 

1. Go to CONFIGURATION > Object > AAA server > Active Directory > Edit Active 

Directory. Configure the AD server that has the same settings as step 2 of “SSO 

Agent Installation”.  

 
2. Go to CONFIGURATION > Object > User/Group > User and add a new 

ext-group-user.  

Ex: csosecurity. The domain user “Amy” must belong to this group in the AD. 
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3. Go to CONFIGURATION > Object > Auth. Method and add “group ad” in the 

default authentication method. 

 
4. Go to CONFIGURATION > Web Authentication > SSO. 

Fill-in the Pre-Shared Key which is configured in the SSO Configuration.   

 
5. Go to CONFIGURATION > Web Authentication > Web Authentication Policy 

Summary to add a new authentication policy.  

Enable the “Single Sign-on” checkbox to be authenticated by the SSO. 
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Verification 

1. On the client's laptop, login using the domain account "Amy". 

Example: CSO\Amy 

Open the browser or application on the client's laptop to trigger traffic to pass to 

the USG. The client “Amy” can surf the Internet directly without extra 

authentication.  

 

2. Check SSO Agent Log. User login is successful and has sent information to the 

USG’s GW (192.168.1.1) successfully. 

 

 
3. Check the Logon user lists on the SSO Agent. The user “Amy” is in the logon list. 
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4. Go to MONITOR > System Status > Login Users.  

The client “Amy” is on the current user list with type SSO. 
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Scenario 11 – WLAN Controller Function on USG 

11.1 Application Scenario 

USG with 4.10 firmware supports the AP controller function. 

You can follow the steps to control your AP device.  

 

 

11.2 Configuration Guide 

Management of external AP device 

(1) Add an SSID object on the device 

Go to Configuration > Object > AP Profile > SSID > SSID list, and click on the “Add” 

button. 

 
(2) Go to Configuration > Object > AP Profile > Radio, and click on the “Add” button 

to add 2.4G and 5G radio objects, and set the SSID profile to this object. 
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(3) Connect your AP to the LAN interface (this document is using NWA 3560-N to test). 

a. The AP must be set as managed mode. 

b. After the connection is successful, the NWA will start upgrading the firmware 

from the USG. 

After upgrading the firmware successful, you will see the MAC address and model 

name in the GUI. 

 
(4) Apply the AP profile on the NWA. 
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(5) Verify the SSID on your network (the SSID is “For_test”) 

 
 

 

 

 

Management of Local AP interface (Only for USG40W & USG60W) 

(1) Add 2 SSIDs in the SSID list (LAN1 and LAN2 subnet) 

Go to Configuration > Object > AP Profile > SSID > SSID list and click on the “Add” button 

to create SSID object. 

Disable “VLAN support” and select the “LAN1” interface in Local VAP Settings.  

 
 

Disable “VLAN support” and select the “LAN2” interface in Local VAP Setting. 

 
(2) Add AP profiles and select these 2 SSID objects in the rule. 

Go to Configuration > Object > AP Profile > RADIO and click on the “Add” button to 
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create the AP profile 

2.4G Band 

 
5G Band 

 
(3) Apply AP profiles to the Local AP interface 

Go to Configuration > Wireless > AP Management and click the local AP (IP address is 

172.0.0.1) to edit the rule. 

Apply the AP profiles to this rule. 

 
Verification: 

If you have connected to For_LAN1 SSID, then you will get the LAN1 subnet IP address. If 

you connect to For_LAN2, then you will get the LAN2 subnet IP address. 
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Scenario 12 – Device HA on the USG 

 

12.1 Application Scenario 

Setup the Device HA environment. 

 
 

 Master device Backup device 

WAN interface IP 10.59.3.100/24 10.59.3.100/24 

WAN Management IP 10.59.3.101/24 10.59.3.102/24 

LAN1 Interface IP 192.168.1.1/24 192.168.1.1/24 

LAN1 Management IP 192.168.1.11/24 192.168.1.12/24 

Cluster ID 1 1 

 

12.2 Configuration Guide 

On Master setting: 

(1) Go to Configuration > Network > Interface > Ethernet to check the WAN and LAN 

interface setting. 

WAN interface is: 10.59.3.100/24 

LAN interface is: 192.168.1.1/24 

 
(2) Go to Configuration > Device HA > Activate-Passive Mode to add the 

management interface on the master device. 
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The Device Role must be set as “Master”. 

WAN management IP address is: 10.59.3.101 

LAN management IP address is: 192.168.1.11 

 
(3) Go to Configuration > Device HA > General to enable the Device HA function. 

After you have enabled the Device HA function, you will see the interface that was 

monitored above. 

 
On Backup setting: 

(4) Go to Configuration > Network > Interface > Ethernet to check the WAN and LAN 

interface setting. 

WAN interface is: 10.59.3.100/24 

LAN interface is: 192.168.1.1/24 

 
(5) Go to Configuration > Device HA > Activate-Passive Mode to add the 

management interface on the backup device. 

The Device Role must se as “Backup”. 

WAN management IP address is: 10.59.3.102 

LAN management IP address is: 192.168.1.12 
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(6) Go to Configuration > Device HA > General to enable Device HA function. 

After you have enabled the Device HA function, you will saw the interface that was 

monitored above. 

 
Verification: 

You can check the status of the Device HA in the GUI. 

The status of the master device will be “Master/Activate”. 

 
The status of the backup device will be “Backup/Stand-By” 
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Scenario 13 – Activating Device HA Pro 

13.1 How to Enable Device HA Pro 

The Device HA feature acts as a failover when one of the devices in the network is dead 

or can’t access the Internet. Therefore, this is a popular feature for network 

environments. In the previous firmware version, the USG supports AP 

(Activate-Passive/Master-Backup) mode. In V4.20, the Device HA feature is enhanced 

and named Device HA Pro. 

 

In Device HA Pro, a “heartbeat link” is added for monitoring the interface status and 

synchronizing settings. Follow the steps below to deploy the Device HA Pro feature in 

your network environment. 
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Device HA Pro License  

1. The Device HA Pro feature is license required. You must register both of your devices on 

the myZyXEL.com server first. Then make sure the Device HA Pro license is available on 

both of your devices. 

 
Behavior of the Device HA Pro 

The behavior of the Device HA Pro includes a heartbeat link to monitor the “activate” 

device’s interface status. If one of the monitored interfaces is dead or fails, the “passive” 

device’s status will became “activate”. (This means only 1 device’s status can be “activate” 

at a time.) 

Be aware that the Device HA status of the devices might constantly change due to the 

network environment situation. In the current firmware design, Device HA Pro will not fallback 

when the primary device interface is working normally again. 

Device-HA Pro Settings:  

A. Enable configuration provisioning on the activated device 

--This function is for the secondary device. If you are configuring the primary 

device, this function is unnecessary. 

B. Serial number of the licensed device for license synchronization  

--Entering the serial number of license from the myZyXEL.com server. 

C. Configure the Device HA Pro interface  

-- Enter the management IP address of the active and passive devices. Also, 

enter the password for synchronizing configuration with each other. 

D. Monitoring Interfaces 

--Select the interfaces which you would like to monitor. 

E. Synchronization 

-- Enable failover when one of the interfaces fails. 
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The Main Function of the Device HA Pro 
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Heartbeat Link 

The heartbeat port is a new physical port on the device. 

After you have enabled Device HA Pro, the devices will transmit multicast packets 

(UDP 694) to check each device’s status. 

When the passive device is working properly, the system LED light will be on. Only 

the heartbeat port’s LED light can be on. 

 

Suggestions 

(1) Transfer all of the licenses to the primary device. This helps to avoid the system from 

recounting licenses every time. 

(2) Enable the connectivity check function on the monitored interfaces. When an 

interface doesn’t receive any response from the remote server for a certain period 

of time, the device will consider the interface status as fail. Then the Device HA Pro 

feature will change the status of the interface. 

  



ZyXEL – USG Application Notes 

89 
 

13.2 How do I Configure Device HA Pro in My Current Environment? 

 

1. License 

The Device HA Pro feature is license required. Please go to register both of your devices 

on myZyXEL.com and make sure the devices have the license after syncing with the 

myZyXEL.com server. 
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2. Configurations on the Primary Device 

 Go to the Configuration > Device HA > Device HA Pro screen. 

 -Enter the device’s license serial number from the myZyXEL.com server. 

 -Enter the management IP address after enabling the Device HA Pro feature. 

 -Select the interfaces which you would like to monitor. 

 -Enable failover when an interface fails.  

       -Click Apply. 
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 Go to the Configuration > Device HA > General screen. 

 - Select Enable Device HA and click Apply to enable Device HA Pro. 
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3. Configurations on the Secondary Device 

 Go to the Configuration > Device HA > Device-HA Pro screen. 

 -Select Enable Configuration Provisioning From Active Device. 

       -Click Apply. 

 
  



ZyXEL – USG Application Notes 

93 
 

Go to the Configuration > Device HA > General screen. 

 -Select Enable Device HA and click Apply. 

 -Before the Device HA Pro feature is enabled on the secondary device, a warning 

message will pop-up for you to confirm. Click OK to enable it. 

 
4. Connecting the Device HA Pro Port 

The Device HA Pro port is a new physical port on the DUT. You can use a cable to 

connect the devices with each other. 
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Scenario 14 — Content Filter 2.0 - HTTPs Domain Filter 

14.1 Application Scenario 

The Content Filter 2.0 - HTTPs Domain Filter allows you to block HTTPs websites by category 

service without SSL-Inspection. The filtering feature is based on 64 categories built in 

ZyWALL/USG such as pornography, gambling, hacking, etc.  

When user makes HTTPS request, the information contains a Server Name Indication (SNI) 

extension fields in server FQDN. Using the SNI to query category from local cache then cloud 

database, then take action when it matches the block category in Content Filter profile.  

 

14.2 Configuration Guide 

Set Up the Content Filter on the ZyWALL/USG  

1. Go to CONFIGURATION > UTM Profile> Content Filter > Profile > General Settings. Select Enable 

HTTPS Domain Filter for HTTPS traffic. 

 

 
 

2. Go to CONFIGURATION > UTM Profile> Content Filter > Profile Management > Add Filter Profile > 

Test Web Site Category. Type URL to test the category and click Test Against Content Filter 

Category Server. 

  

 

3. You will see the category recorded in the external content filter server’s database for both 

HTTP and HTTPS Domain you specified.  
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4. Go to CONFIGURATION > UTM Profile> Content Filter > Profile Management > Add Filter File > 

Custom Service. Configure a Name for you to identify the Content Filter Profile and select 

Enable Content Filter Category Service. Select Block to prevent users from accessing web 

pages that match the managed categories that you select below. Select Log to record 

attempts to access web pages that match the unsafe categories that you select below. 

  

5. Scroll down to the Managed Categories section, select categories in this section to control 

access to specific types of Internet content. You must have the Content Filtering license to 

filter these categories. 

 

Set Up the Security Policy on the ZyWALL/USG 

1. Go to CONFIGURATION > Security Policy > Policy Control, configure a Name for you to identify 

the Security Policy profile. Scroll down to UTM Profile, select Content Filter and select a profile 

from the list box (Social_Net_Block in this example).  
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Set Up the System Policy on the ZyWALL/USG 

1. Go to CONFIGURATION > System > WWW > Show Advanced Settings > Other, click Enable 

Content Filter HTTPS Domain Filter Block/Warn Page. 
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Test the Result 

1. Type http://www.facebook.com/ or https://www.facebook.com/ into the browser, the error 

message occurs.  

 

 

2. Go to the ZyWALL/USG Monitor > Log, you will see [alert] log message such as below. HTTP 

traffic log matches (Content Filter) and HTTPS traffic log matches (HTTPS Domain Filter) in 

message field. 

Monitor > Log 

 

 

 

 

 

 

http://www.facebook.com/
http://www.facebook.com/
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Scenario 15 — Content Filter 2.0 - Geo IP Blocking 

15.1 Application Scenario 

The Content Filter 2.0 - Geo IP blocking offers identify the country based on IP address, it 

allows you to block the client accessing to certain country based on organizational policy. 

When user makes HTTP or HTTPS request, ZyWALL/USG query IP address from MaxMind 

database, then take action when it matches the block country in Content Filter profile.  

If you have a local web site and your primary market is local people, then there is no need to 

let any other countries index or waste bandwidth on your server.  

Also this feature offer an easy and effective way to prevent bogus, bots, brute force hacks, 

vulnerability scanners, and web crawlers from other countries. 

 

15.2 Configuration Guide 

Set Up the Address Objet with Geo IP on the ZyWALL/USG  

1. Go to CONFIGURATION > Object > Address/Geo IP > Address > Add Address Rule. 
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2. Go to CONFIGURATION > Object > Address/Geo IP > Address, you can see the customized 

GEOGRAPHY address. 

 
 

 

 

Set Up the Security Policy on the ZyWALL/USG  

1. Go to CONFIGURATION > Security Policy > Policy Control, configure a Name for you to 

identify the Security Policy profile. Set Geo IP traffic from WAN to LAN allow source from 

local country (geo_allow_policy in this example).  

 

 

2. Go to CONFIGURATION > Security Policy > Policy Control, configure a Name for you to identify 

the Security Policy profile. Set traffic from WAN to LAN deny (geo_block_policy in this 

example).  
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Test the Result  
1. Type http://csosuppport.ddns.net/ into the browser, and the http can be reached. 

 

 

2. Go to the ZyWALL/USG Monitor > Log, you will see [notice] log message such as below. Traffic 

matches Geo IP policy will be blocked and shows in message field. 

 

 

http://csosuppport.ddns.net/
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Scenario 16 — VPN Failover with VTI 

16.1 How to Create a VTI for VPN Tunnel 

With VTI (Virtual Tunnel Interface), the user can create an interface for the VPN tunnel. 

Through VTI, the VPN tunnel can be managed as an interface with more flexibility. It 

allows the user to configure a trunk with VTI to achieve VPN load balancing. Besides, the 

user can configure a policy route or static route by selecting the VTI as the next-hop. 

Furthermore, it allows the user to configure the BWM rule with a VTI object. This example 

illustrates how to create a VTI object and configure a policy route with the VTI. 

Furthermore, it applies the VTI to the WAN trunk to achieve VPN load balancing. 

  

VTI Deployment Flow  

1 Configure the VPN gateways. 

2. Configure a VPN tunnel for each VPN gateway with the application scenario VPN Tunnel 

Interface. 

3. Create a VTI for each VPN tunnel. 

4. Create a trunk with the VTIs. 

5. Configure a policy route.  

6. Connect the VPN tunnels. 

 

Configuration Guide 

Network Conditions 

USG1 

- WAN1 IP: 10.251.31.114 
- WAN2 IP: 10.251.31.167 

- VTI 1: 10.10.10.10 
- VTI 2: 10.10.11.10 

- LAN1: 192.168.1.0/24 
 

 

USG2 

- WAN1 IP: 10.251.31.21 
- WAN2 IP: 10.251.31.107 

- VTI 1: 10.10.10.20 
- VTI 2: 10.10.11.10 

- LAN1: 192.168.11.0/24 
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On USG1:  

(1) Configure the VPN gateways 

Go to CONFIGURATION > VPN > IPSec VPN > VPN Gateway > Add. 

Create the VPN gateway HQ1 with wan1. 

 
 

In the same screen, create the VPN gateway HQ2 with wan2. 

 
 

(2) Configure the VPN tunnels 

Go to CONFIGURATION > VPN > IPSec VPN > VPN Connection > Add. 

Create a VPN tunnel for the VPN gateway HQ1.  

Select VPN Tunnel Interface as the application scenario. 
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In the same screen, create a VPN tunnel for the VPN gateway HQ2.  

Select VPN tunnel Interface as the application scenario. 

 

 

(3) Create VTIs 

Go to CONFIGURATION > Network > Interface > VTI > Add. 

Create a VTI for the VPN tunnel HQ1. 
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Enable the connectivity check. Enter the IP address of vti1, which is configured on USG2. 

 
 

In the same screen, create a VTI for the VPN tunnel HQ2. 

 
 

Enable the connectivity check. Enter the IP address of vti2, which is configured on USG2. 

 
 

(4) Create a new trunk 

Go to CONFIGURATION > Network > Interface > Trunk > User Configuration > Add. 

Add vti1 and vti2 to the new trunk.  

 
 

(5) Configure a policy route 
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Go to CONFIGURATION > Network > Routing > Policy Route > Add and enter the following 

parameters. 

Source Address: LAN1_SUBNET (192.168.1.0/24) 

Destination Address: BO_subnet (192.168.11.0/24) 

Next-Hop: HQ_vti_trunk 

SNAT: none 

 

 

(6) Connect the VPN tunnels 
Go to CONFIGURATION > VPN > IPSec VPN > VPN Connection. 

Connect the VPN tunnels when the VTIs are ready. 
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In the CONFIGURATION > Network > Interface > VTI screen, you should be able to see that the 

status of the VTI is up when the corresponding VPN tunnel is established. 

 

 

On USG2: 

(1) Configure the VPN gateways 

Go to CONFIGURATION > VPN > IPSec VPN > VPN Gateway > Add. 

Create the VPN gateway BO1 with wan1. 

 
 

In the same screen, create the VPN gateway BO2 with wan2. 
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(2) Configure the VPN tunnels 

Go to CONFIGURATION > VPN > IPSec VPN > VPN Connection > Add. 

Create a VPN tunnel for the VPN gateway BO1.  

Select VPN tunnel Interface as the application scenario. 

 

 

In the same screen, create a VPN tunnel for the VPN gateway BO2.  

Select VPN tunnel Interface as the application scenario. 

 
 

(3) Create VTIs 

Create a VTI for the VPN tunnel BO1 in the CONFIGURATION > Network > Interface > VTI > 

Add screen. 

Be aware that the IP address of this VTI must be in the same subnet as vti1 on USG1. 

In this example, the IP address and subnet mask of vti1 on USG1 is 10.10.10.10 and 

255.255.255.0 respectively. The IP address of vti1 on USG2 must be in the subnet of 

10.10.10.0/24. 

 

 



ZyXEL – USG Application Notes 

108 
 

 

 
 

Enable the connectivity check. Enter the IP address of vti1, which is configured on USG1. 

 

 

In the same screen, create a VTI for the VPN tunnel BO2. 

Be aware that the IP address of this VTI must be in the same subnet as vti2 on USG1. 

In this example, the IP address and subnet mask of vti2 on USG1 is 10.10.11.10 and 

255.255.255.0 respectively. The IP address of vti2 on USG2 must be in the subnet of 

10.10.11.0/24. 
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Enable the connectivity check. Enter the IP address of vti2, which is configured on USG1. 

 
 

(4) Create a new trunk 

Go to CONFIGURATION > Network > Interface > Trunk > User Configuration > Add. 

Add vti1 and vti2 to the new trunk.  

 
 

(5) Configure a policy route 

Go to CONFIGURATION > Network > Routing > Policy Route > Add and enter the following 

parameters. 

Source Address: LAN1_SUBNET (192.168.11.0/24) 

Destination Address: HQ_subnet (192.168.1.0/24) 

Next-Hop: BO_vti_trunk 

SNAT: none 
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(6) Connect the VPN tunnels 

Go to CONFIGURATION > VPN > IPSec VPN > VPN Connection. 

Connect the VPN tunnels when the VTIs are ready. 

 

 

Go to CONFIGURATION > Network > Interface > VTI. You will see that the status of the VTI 

is up when the corresponding VPN tunnel is established. 

 

 

16.2 Verification 

Task 1: The PC in LAN1 of USG1 is able to ping the PC in LAN1 of USG2 and vice versa. 

PC of USG1: 192.168.1.34 

 

PC of USG2: 192.168.11.33 

 

 

 

 

 

 

 

 



ZyXEL – USG Application Notes 

111 
 

 

 

Task 2:  Unplug wan1 of USG1. The PC in LAN1 of USG1 is still able to ping the PC in LAN1 of USG2 

and vice versa because the VTI trunk is used as the next-hop in the policy route. 

Check the status of the USG1 PC (192.168.1.34) in the MONITOR > VPN Monitor > IPSec screen. 

 

 

 

Check the status of the USG2 PC (192.168.11.33) in the MONITOR > VPN Monitor > IPSec screen. 
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Scenario 17 – How to Activate a Paid Access Hotspot 

17.1 Application Scenario 

In this scenario, many customers need to access the Internet via a paid hotspot. The USG1100 can 

manage access to the Internet effectively. There are two ways to achieve this on the USG1100; 

one method is to use a printer, and the other is to use the PayPal payment service. Customers who 

use the PayPal payment service can pay with their PayPal account to access the Internet. As for 

the printer, customers can purchase tickets that are generated by a thermal printer from the store 

or hotel’s reception desk. By using the account and password information on the tickets, 

customers can access the Internet with a web browser. 

 

 

 

 

 

17.2 Configuration Guide 
Network Conditions  

 SP350E: 

 Default IP address (DHCP): 192.168.2.4 

 User name: admin 

 Password: 1234 

 Port number: 9100 
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Printing a Ticket for Accessing the Internet 

Configurations on the USG1100: 

1.  Configure the Printer Manager screen settings on the USG1100. 

(1) Go to Configuration > Printer Manager > General. 

 

 

(2) Enable the printer manager and add the printer by entering its IP address. Click OK. 
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2. Go to Configuration > Monitor > Printer Status. Check if the status of the printer shows 

“sync success“. 

 

 

3. Go to Configuration > Printer Manager > Printout Configuration. In this screen, you can 

choose whether you want to use the default printout configuration or a customized one. If 

you choose Use Customized Printout Configuration, you can customize the ticket 

information by downloading the example and modifying the ticket. Then upload the 

customized printout configuration to the system. 
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4. Click Printout Preview to display a pop-up preview window of the default or 

customized printout configuration ticket format. 

 

 

 

Using the PayPal Payment Service to Access the Internet 

Configurations on the USG1100 

1. Go to Configuration > Billing > Payment Service. Select Enable Payment Service and 

enter the payment provider’s information, which should be provided to you by PayPal 

after successfully applying for your PayPal account. 

 

2. Test the dynamic account to pay the bill by using the payment function. 

(1) Open the Login screen after enabling the payment function. You will see a link to 

create an account. Click it to be redirected to the billing profile screen. 
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(2) As a test,  select the billing_3hr billing profile and click OK. You will be redirected to 

the PayPal authentication screen. 
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(4) Log into the PayPal screen to check your order. 

 

 

(5) After clicking the Agree and Continue button, you can click Pay Now to pay the bill. 

 

 

 

(6) After clicking the Pay Now button, PayPal will display a pop-up window as shown 

below. After 10 seconds, you will be redirected to the hotspot’s login information. 
 

 

(7) Now you can see the login username and password for the hotspot. 
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(8) You can log into the device with the provided username and password during the 

allocated time period. 
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Scenario 18 – How to Activate a Free Access Hotspot 

18.1 Application Scenario 

 

Some hotels need to provide free Internet services to hundreds of guests on a daily basis, and 

managing the Internet access for so many people can be very complicated without the right 

equipment. With web authentication methods such as user agreement and web portal, hotel 

guests are redirected to a web-based authentication portal upon the first attempt to access the 

network. In some countries, the law requires the identification and tracking of users who use public 

Internet access. The USG1100 can authenticate people by forcing them to receive an 

authentication code via SMS on their phone. In this way, the USG1100 can authorize the user’s 

Internet access via their mobile phone number and keep track of the device in case of illegal 

activities via the hotspot. Guests can get free access to the Internet in a matter of seconds simply 

by entering all required personal contact information and agreeing to the policy of user 

agreement. If a user that does not have a guest account wants to access the free Internet for a 

specified period of time, his or her mobile phone number must be entered to receive the guest 

account information by SMS. 

User Agreement 

 

18.2 Configuration Guide 

Network Conditions 

 

 WAN: 10.251.31.112 

 LAN 1: 192.168.1.1/255.255.255.0 

 User’s laptop: 192.168.1.33 
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Configurations on the USG1100 

The user agreement of this feature allows clients to access the Internet without a guest account. 

An advertisement webpage is used as the first page when an authenticated user attempts to 

access the Internet. 

1. On the USG1100, go to Configuration > Web Authentication > General. Select Enable 

Web Authentication and click Add in the Web Authentication Policy Summary section. 

(1) Select Enable Policy. 

(2) Select default-user-agreement as the Authentication Type.  

(3) Click OK to add the policy. 
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2. Go to Configuration > Hotspot > Advertisement. 

(1) Select Enable Advertisement. 
(2) Add the URL of the website that you want to advertise. 

 

Verification 

1. When a client attempts to access the Internet via a browser, he/she will be redirected to the 

user agreement page.  
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2. The advertisement webpage will be displayed in a new window and it is the first page that 

appears whenever the user connects to the Internet.  
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Enable the Free Time Feature 
Configurations on the USG1100 

On the USG1100, you need to enable the SMS service and select SMS as the delivery method 

in the Free Time feature. 
 

1. Register for a ViaNett account at http://www.vianett.com. 

 

 

2. Enter all the required information. 

 

 

 

 

 

 

http://www.vianett.com/
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3. After the form has been submitted, the account information will be sent to your 

E-mail address. 
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4. Enter the activation code and proceed to make the payment. 

 

 

 

5. Fill-in the credit card information to complete the payment. 

 
The payment is complete. 
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6. After the ViaNett account is ready, go to the USG1100’s Configuration > Hotspot > SMS 

screen. 

(1)Enable SMS. 

(2)Fill-in your local phone country code as the default country code. 

(3) Add authentication policy for every source. 

 

7. Go to Configuration > Hotspot > Free Time. 

(1) Select Enable Free Time and set up the free time period. By default, the Reset Time is at 

AM 00:00. You can also set up how many times a MAC address can access the Internet. 

(2) Select SMS as the method to deliver the login information to the mobile phone. 

 

8. Go to Configuration > Web Authentication. Select Enable Web Authentication and click 

Add in the Web Authentication Policy Summary section. 
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9. Select Enable Policy, Force User Authentication, and then select default-web-portal as the 

Authentication Type. 

 

Verification 

1. The user will be redirected to the Login screen before he/she is permitted to access the 

Internet. Click on the link to get a free account. 
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2.  Select Free Time as the service plan. Then submit your country code and mobile phone 

number. 

 

3. The account and password will be sent to your mobile phone. 

 

4. Check your account information. 
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5. Fill-in the account information received on your mobile phone and click Login. 

 

6. Now the client can start accessing the Internet. 
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Scenario 19 – Link Aggregation Group (LAG) 

19.1 Application Scenario 

A Link Aggregation Group (LAG) allows you to combine a number of physical ports together to 

create a single high bandwidth data path. It helps to implement the traffic to perform load 

balancing or failover features, depending on the situation of the actual case. 

 

Before you begin: 

LAG interface supported models: ZyWALL 310/1100/1900, USG 310/1100/1900 

The link aggregation supported models have Active-backup, 802.3ad (LACP), and Balance-alb 

modes. 

Link aggregation supports IPSec tunnel, VLAN, and bridge interface. 

Device HA Pro is supported on the LAG interface but Device HA is not. 

19.2 Configuration Guide 

 

 LAG Application Scenario: Active-backup, 802.3ad, Balance-alb 

 

Active-backup Mode: 

(Does not require switch configuration and one or multiple switches can be used.) 

 

Only the USG needs to be configured. You do not need to change any settings on the 

switch. 

 

On the USG, go to Configuration > Network > Interface > LAG. 

Choose the proper interface type and zone depending on the case. Also, select the slave 

ports that will be added in the LAG interface.  

The interface format will be lagx (x = 0~3). 
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Link Monitoring: 

You can choose link up/down detection (specify the MII link monitoring frequency or ARP 

interval time). 
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Updelay is the time to wait to enable the slave port after the device detects the link 

recovery.  

Downdelay is the time to wait to disable the slave port after the device detects the link 

failure. 

 

 
The taget IP can be the Layer 3 device or the host IP, can be reachable by the USG. 

 

802.3ad (LACP) Mode: 

(Both devices need to be configured. Only one switch can be used. The port speed and 

duplex must be the same.) 

 

 
The USG should be connected to only one switch and its settings should be the same as the 

switch. This utilizes all slave network interfaces in the active aggregator group according to 

the 802.3ad specification. 
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Xmit Hash Policy: 

Xmit Hash policy: Select layer2 or layer2+3. 

Select layer 2 if the LAG interface is connect to a layer 2 subnet. 

Select layer 2+3 if the LAG interface is connect to a network with a router or a L3 switch. 

 

 
 

LACP rate: 

The interval can be fast (every second) or slow (every 30 seconds). 

 

Balance-alb Mode: 
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(Does not require configuration on the switch and one or multiple switches can be used.) 

 

 
The settings are the same as the active-backup mode. 

 

The VLAN interface is cross-connected to different switches and the link statuses on both switches are active. 

 

In this case, the LAG interface mode must be set to Balance-alb. 

 

The VLAN interface is cross-connected to different switches (fault tolerance). 
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Only one link connection is up and the other is down. In this case, you will need to use the active-backup 

mode. 

 

 

You can find the LAG interface in the VLAN interface.. 

 

 

 

 


