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Scenario 1 ñ How to Configure NAT if you have 

Internet -facing Public Servers  

1.1 Application Scenario  

It is a common practice to place company servers behind the USGõs 

protection; while at the same time letting WAN side clients/servers access 

the intranet servers. To give an example, the company may have an 

internal FTP server, which needs to be accessible from the Internet as well. 

To fulfill this requirement, the user can configure a NAT mapping rule to 

forward the traffic from  the  Internet side to intranet side. This feature  does 

not  only ensure service availability , but also helps avoid exposing the 

serverõs real IP address from being attacked.  

 

1.2 Configuration Guide  

Goal to achieve:  

User Tom can access the Internet FTP server by accessing the 

Internet -facing  the  WAN IP address.  

Network Conditions: USG-50:  

- WAN IP: 59.124.163.152  

- FTP server IP: 192.168.50.33 
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Configuration  

Step 1. Go to CONFIGURATION > Network > NAT to open the configuration 

screen.  

 

Step 2. Click  on  the Add button to create a mapping rule.  

Step 3. In this page , the  user needs to configure:  

- Ruleõs name  

- Select Virtual Server type to let USG -50 do packet forwarding  

- Fill-in the Original IP (WAN IP) address  

- Fill-in the Mapped IP (Internal FTP server IP) address  

- Select the service to be mapped (FTP); the ports will be selected 

automatically  

 

Step 4. Go to CONFIGURATION > Security Policy > Policy Control to open 

the firewall configuration screen.  

Here assume the user already assigned th e WAN interface to WAN zone 

and LAN interface to LAN1 zone.  

Step 5. Click on the Add  button to create a firewall rule to enable the FTP 

service to pass from WAN to LAN1.  
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Step 6. The user can create an address object for the internal FTP server for 

further configuration usage. Click  on  Create new Object for this function.  

 

Step 7. Configure the rule to:  

- Allow access from WAN to LAN1  

- Source IP address is not specific  

- Destination IP address is the FTP serverõs address  

- Select FTP service (with port 20/21) to be enabled  

- Select the allow action for matched packets  
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Step 8: Click on the OK button, you will see the rule in policy control.  
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Scenario 2 ñ Secure Site -to-site Connections 

using  IPSec VPN ð IPv4 with  IKEv2 / IPv6 

2.1 Application Scenario  

IPv4 with IKEv2 

We want to use IKEv2 to establish a VPN tunnel between the HQ and 

Branch  Office .  

 

IPv6 (with IKEv2 only)  
ISP has changed the environment to IPv6. We applied for IPv6 address 

pool for internal use. So we have to change  use the IPv6 address to 

establish  an  VPN tunnel between  the  USG. 

 

2.2 Configuration Guide   

IPv4 

Network Conditions:  

USG-40W with static WAN:  

- WAN IP: 59.124.163.155 
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- Local subnet: 192.168.100.0/24  

 

USG-40W with PPPOE WAN: 

- PPPOE IP: 220.137.67.76 

- Local subnet: 192.168.200.0/24  

 

IPSec VPN Conditions:  

Phase 1: Phase 2: 

IKE version: IKEv2 Active Protocol: ESP  

Authentication: 1234567890  Encapsulation Mode: Tunnel  

Local/Peer ID type: IPv4 0.0.0.0 / 

Any  

Encryption Algorithm: DES  

Encryption Algori thm: 3DES  Authentication Algorithm: SHA1  

Authentication Algorithm: MD5  Perfect Forward Secrecy: None  

Key Group: DH1   

 

Goal to achieve:  

Establish an  IPSec VPN tunnel between two USGs with the above 

configuration.  

Step 1. Go to CONFIGURATION > VPN > IPSec VPN > VPN Gateway to open 

the configuration screen.  

Step 2. Click  on  the Add button to add a VPN gateway rule.  

 

Step 3. To configure the VPN gateway rule, the user needs to fill -in:  

- VPN gateway name  

- Enable IKEv2 protocol  

- Gateway address; both local (My Address) and peer (Peer GW Address)  

- Authentication setting  

Â Pre-Shared Key  

Â ID Type setting (Local and Peer side)  

- Phase-1 setting  

Â Negotiation mode  

Â Encryption algorithm  

Â Authentication algorithm  
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Â Key Group  
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Step 4. Go to CONFIGURATION > VPN > IPSec VPN > VPN Connection to 

open the configuration screen to configure the phase -2 rule.  

 

Step 5. Click on the Add button to add a rule.  

 

 

Step 6. To configure the phase -2 rule, the user needs to fill -in:  

- VPN connection name  

- VPN gateway selection  

-Policy for  

Â Local network side  

Â Remote network side  

- Phase-2 settings  

Â Active protocol  

Â Encapsulation mode  

Â Encryption algorithm  

Â Authentication algorithm  

Â Perfect Forward Secrecy  
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Step 7. After setting the rule, the user can select the rule and click  on  the 

Connect button to establish the VPN link. Once the tunnel is established, a 

connected icon will be displayed in front of the rule.  

 

 

Step 8. When the VPN tunnel is established, the user can find the SA 

information on MONITOR > VPN MONITOR > IPSec. 
 

IPv6 
Step  1. Add a n IPV6 VPN phase I on USG1. Go to CONFIGURATION > 

VPN > IPSec VPN > VPN Gateway . 

My Address: 2002:3b7c:a397:2:ee43:f6ff:fefc:c4b3  

Peer Gateway Address: 2002:3b7c:a397:2:b2b2:dcff:fe70:c1d6  

Pre-Shared Key: 1 2345678 

 

Step 2. Add a n IPv6 VPN phase II on USG1. Go to CONFIGURATION > 
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VPN > IPSec VPN > VPN Connection . 

VPN Gateway: USG1_GW  

Local policy: 2002:3b7c:a397:2222::/64  

Remote policy: 2002:3b7c:a397:1111::/64  

 

Step  3. Add an IPV6 VPN phase I on USG2. Go to  CONFIGURATION > 

VPN > IPSec VPN > VPN Gateway . 

My Address: 2002:3b7c:a397:2:b2b2:dcff:fe70:c1d6  

Peer Gateway Address: 2002:3b7c:a397:2:ee43:f6ff:fefc:c4b3  

Pre-Shared Key: 12345678  

 

Step  4. Add an IPV6 VPN phase II on USG2. Go to CONFIGURATION > 
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VPN > IPSec VPN > VPN Connection . 

VPN Gateway: USG2_GW  

Local policy: 2002:3b7c:a397:1111::/64  

Remote policy: 2002:3b7c:a397:2222::/64  

 

Step 5. When the VPN tunnel is established, the user can find the SA 

information on  

MONITOR > VPN MONITOR > IPSec.  
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Scenario 3 ñ Connect to USG using IPSec IKEv2 

in Windows 7  

3.1 Application Scenario  

INTERNET

IKEv2

Lan

192.168.100.1/24

192.168.100.0/24

WAN

usg210.dyndns-ip.com

Windows 7 supports IPSec IKEv2 with certificate authentication.  

This section provides information on how to configure the IKEv2 (Internet 

Key Exchange) on a Windows 7 PC via certificates.  

 

3.2 Configuration Guide  

Network Conditions:  

USG 210: 

- WAN1 IP: usg210.dyndns -ip.com  

- Local subnet: 192.168.100.0/24  

 

USG-210 VPN Conditions:  

Phase 1: 

- Authentication Method: Certificate  

- Local /Peer ID type: DNS / Any  

- Encryption and Authentication Algorithm:  

 3DES/SHA1, AES128/MD5, AES128/SHA1 

- Key Group: DH2  

 

Goal to achieve:  

Establish an IPSec VPN tunnel from Windows 7 using IKEv2 protocol.  
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Step 1. Go to CONFIGURATION > Object > Certificate > My Certificates tab 

to add a new certificate for Windows clients.  

 

 

Step 2. Go to CONFIGURATION > Object > User/Group to create a user 

account . Add this account into IKEv2 users group object. This group object 

will be used in IPSec VPN phase -1 EAP (Extended Authentication Protocol) 

field.  
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Step 3. Go to CONFIGURATION > VPN > IPSec VPN > VPN Gateway to open 

the configuration screen.  

 

Step 4. Click on the Add button to add a VPN gateway rule. 

 

 

Step 5. To configure the VPN gateway rule, the user needs to fi ll-in: 

- VPN gateway name:  

- IKE Version: IKEv2 

- Gateway address: both local (My Address) and peer (Dynamic Address)  

- Authentication setting:  

Â Certificate  

- Phase-1 setting  

Â Encryption and Authentication Algorithm:  

1) 3DES / SHA1 

2) AES128 / MD5 

3) AES128 / SHA1 

4) Key Group DH2  

- Extended Authentication Protocol:  

Â Enable Extended Authentication Protocol  

Server Mode  

 AAA Method: default  

 Allowed User: IKEv2_users 
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Step 6. Go to CONFIGURATION > Object > Address to create an address 
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object . This address object's IP address will  be  assigned  to  the  Windows 

IKEv2 client's machine.  

 

 

Step 7. Go to CONFIGURATION > VPN > IPSec VPN > VPN Connection to 

open the configuration screen to configure the phase -2 rule.  

 

Step 8. Click  on the  Add button to add a  rule. 

 

 

Step 9. To configure the phase -2 rule, the user needs to fill -in:  

- VPN connection name  

- VPN gateway selection  

- Policy for  

Â Local network side  

- Configuration Payload  

Â Enable Configuration Payload  

IP Address Pool:  

- Phase-2 setting  

Â Active protocol  

Â Encapsulation mode  

Â Encryption algorithm  

Â Authentication algorithm  

Â Perfect Forward Secrecy  
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Step 10. Export the certificate, which  was generate d  in step 1 , and save it 

to  the  Windows 7 machine.  

 

 

Step  11. In the Windows 7 machine, go to Start > mmc >   
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Step 12. In the mmc console, click  on  File > Add/Remove Snap -in... >   
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Step 13. In the left panel, select the Certificates and click  on the  Add  

button . 

 

 

Step 14. Select the  Computer account > Next button > select Local 

computer > Finish button  > OK button . 
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Step 15. Open up the Certificates (Local Computer) > Trusted Root 

Certification Authorities > right -click  on  Certificate > All Tasks > Import . 
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Step 16. Select the certificate , which was generated by the USG . 

 

 

Step 17. Create the Windows IPSec connection profile . 
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Step 18. Modify  the  IPSec connection profile. Go to Security >  

Type of VPN:  IKEv2  

Data encryption:  Require s encryption (disconnect if server declines)  

Authentication:  Use Extensible Authentication Protocol  (EAP) 
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Step 19. Modify IPSec connection profile. Go to Networking >  and disable 

the TCP/IPv6 checkbox.  

Note: USG 4.10 firmware does not support multiple proposal s. It only 

supports IPv4 proposal selection.  

 

Step 20 . Establish the IPSec tunnel from the Windows 7 machine , and  the  

tunnel will be established successfully.  
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Scenario 4 ñ GRE over IPSec VPN 

Tunnel ðVPN Failover  

4.1 Application scenario  

We want to use VPN tunnels to transfer important files between the 

branch Office and HQ. To prevent the network from getting 

disconnect ed , we configure four WAN interfaces to do redundancy. 

Now, we want to establish two VPN tunnels between the two USGs to 

perform failover,  to ensure  that  the transfer will not be interrupted when 

the fi rst connection encounters a problem. This will create a stable 

environment for the transfer.  

 

4.2 Configuration Guide  

Network conditions:   

USG1 

- WAN1 IP: 192.168.1.33 

- WAN2 IP: 192.168.2.33 

- GRE tunnel interface1: 

10.0.0.1 

- GRE tunnel interface2: 

10.10.0.2 

USG2 

- WAN1 IP: 192.168.3.33 

- WAN2 IP: 192.168.4.33 

- GRE tunnel interface1: 

10.0.0.3 

- GRE tunnel interface2: 

10.10.0.4
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Goals to achieve:  

Use GRE over IPSec VPN to perform the VPN fail -over.  

USG configuration  

Step  1. Add two GRE tunnels on USG1. Go to  CONFIGURATION > Tunnel. 

a.  Add  the  first tunne l 

IP Address: 10.0.0.1, Subnet Mask: 255.255.255.0  

My Address: WAN1, Remote Gateway Address: 192.168.3.33  

 
Place a check in the Enable Connectivity Check  checkbox . Ensure that the  Address is 

the remote GRE tunnel interface.  

 
b.  Add the second tunne l 

IP Address: 10.10.0.2, Subnet Mask: 255.255.255.0  

My Address: WAN2, Remote Gateway Address: 192.168.4.33  
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Place a check in the Enable Connectivity Check  checkbo x. Ensure that the Address is 

the remote GRE tunnel interface.  

 

 
 

Step  2. Add a GRE tunnel trunk on USG1. Go to  CONFIGURATION > Network > 

Interface > Trunk.  

 gre_trunk member:  

 tunnel0: Active  

 tunnel1: Passive  
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Step3. Add two IPSec  VPN tunnels on USG1. Go to  CONFIGURATION > VPN > IPSec 

VPN. 

a.  Add two VPN gateway policies.  

First VPN Gateway policy (USG1 wan1 to USG2 wan1)  

My Address: wan1, Peer Gateway Address: 192.168.3.33  

Pre-Shared Key: 12345678  
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Secondary Gateway policy (USG1 wan2  to USG2 wan2)  

My Address: wan2, Peer Gateway Address: 192.168.4.33  

Pre-Shared Key: 12345678  

 
b.  Add two VPN Connections  

First VPN Connection  

Enable Nailed -Up 

Application Scenario: Site -to -Site 

VPN Gateway: GRE0_GW  

Local policy: 192.168.1.33  

Remote policy: 1 92.168.3.33 

Enable GRE over IPSec  
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Second VPN Connection  

Enable Nailed -Up 

Application Scenario: Site -to -Site 

VPN Gateway: GRE1_GW  

Local policy: 192.168.2.33  

Remote policy: 192.168.4.33  

Enable GRE over IPSec  
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Step  4. Add a policy routes on USG1. Go to CONFIGURATION> Network > Routing . 

  Source: LAN1_Subnet  

  Destination: Remote subnet  

  Next -Hop: gre_trunk  

  SNAT: none 
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Step5. Add two GRE tunnels on the USG2. Go to CONFIGURATION > Tunnel . 

a.  Add first tunne l 

IP Address: 10.0.0.3, Subnet Mask: 255.255.255.0  

My Address: WAN1, Remote Gateway Address: 192.168.1.33  

 
Place a check in the Enable Connectivity  Check  checkbox . Ensure that the Address is 

the remote GRE tunnel interface.  
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b.  Add Second tunne l 

IP Address: 10.10.0.4, Subnet Mask: 255.255.255.0  

My Address: WAN2, Remote Gateway Address: 192.168.2.33  

 
Place a check in the Enable Connectivity  Check checkbox. Ensure that the Address is 

the remote GRE tunnel interface.  
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Step6. Add a GRE tunnel trunk on USG2. Go to CONFIGU RATION > Network > Interface 

> Trunk. 

 gre_trunk member:  

 tunnel0: Active  

 Tunnel1: Passive 

 

 
 

Step  7. Add two IPSec VPN tunnels on USG2. Go to CONFIGURATION > VPN > IPSec 

VPN. 
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a.  Add two VPN Gateways.  

First VPN Gateway  

My Address: wan1, Peer Gateway Address: 192.168.1.33  

Pre-Shared Key: 12345678  

 
Second VPN Gateway  

My Address: wan2, Peer Gateway Address: 192.168.2.33  

Pre-Shared Key: 12345678  

 
b.  Add two VPN Connections.  

First VPN connection  

Application Scenario: Site -to -Site 

VPN Gateway: GRE0_GW  

Local policy: 192.168.3.33  

Remote policy: 192.168.1.33  




















































































































































































